If you have not heard about the Hearbleed virus, you must be aware and take action.  It was discovered this past week and many websites have been vulnerable and you may need to change your password.  Gmail, Netflix, WordPress, Facebook, Box and Dropbox as well as many other popular sites that use OpenSSL for their security were affected.

This website provides some background, sites that were affected and what action you may need to take.  It is being updated regularly, so you may want to check it frequently.

http://mashable.com/2014/04/09/heartbleed-bug-websites-affected/

 

Leave a Reply

Your email address will not be published. Required fields are marked *